It is currently Thu Jul 19, 2018 9:04 am

All times are UTC - 7 hours [ DST ]

Recent News:



Post new topic Reply to topic  [ 23 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: SMB1 upgrade to SMB2?
PostPosted: Sat Jun 23, 2018 3:45 pm 
Offline
1.5TB storage
1.5TB storage

Joined: Tue Oct 01, 2013 12:06 am
Posts: 64
Thanks: 10
Thanked: 2 times in 2 posts
Hi Folks.. LIke a bad penny, Have to come back to the womb for help on a new MSS issue.. Did a few searches here and and could not find any hits? (seems like one search got me into an external advertisement? - we'll tackle that later), Here's the story, and the ask!... Was on holiday for a few weeks, got back yesterday and powered on (no issues) my V1 MSS, opened a word doc and tried to save it to my public folder, and got a microsoft (win10) error message that said my attached drive (to mss) was unreliable running SMB1 and needs to be upgraded to SMB2 or later. Tried to upload pictures as well with same error message result, I can't get past this error. Has anyone else seen this error? Am I just behind the times? I posted pix of message below, HELP!


Attachments:
2018 italy Iceland post mortem.pdf [182.8 KiB]
Downloaded 7 times

_________________
EX495
WHSV1


Last edited by DataGeek on Sun Jun 24, 2018 11:51 am, edited 1 time in total.
Top
 Profile  
Thanks  

Attention Guest: Remove this ad by Registering with the MediaSmartServer.net Forums. It's Free!
PostPosted: Sun Jun 24, 2018 12:33 am 
Offline
1.5TB storage
1.5TB storage

Joined: Tue Oct 01, 2013 12:06 am
Posts: 64
Thanks: 10
Thanked: 2 times in 2 posts
Here is link to Microsoft article:

https://support.microsoft.com/en-us/hel ... in-windows

_________________
EX495
WHSV1


Top
 Profile  
Thanks  
PostPosted: Sun Jun 24, 2018 3:57 am 
Offline
1.5TB storage
1.5TB storage

Joined: Tue Oct 01, 2013 12:06 am
Posts: 64
Thanks: 10
Thanked: 2 times in 2 posts
Another good article on this issue: https://blogs.technet.microsoft.com/fil ... sing-smb1/

_________________
EX495
WHSV1


Top
 Profile  
Thanks  
PostPosted: Sun Jun 24, 2018 11:08 am 
Offline
1.5TB storage
1.5TB storage

Joined: Tue Oct 01, 2013 12:06 am
Posts: 64
Thanks: 10
Thanked: 2 times in 2 posts
Update, tried another win10 desktop, Could access Server fine!

Both Win10 machines running Ver 1803, build 17134.112, one Acer Predator works properly, was a clean win10 load (assume) purchased with Win10 loaded, Asus (not working) is a win7 upgraded machine using Msoft upgrade tool. I also have an unsigned Cert Camera capture card in it that (assume) forces OS to run in "Test mode" (see on lower right corner of desktop a "Watermark" showing:

Test Mode
Windows 10 Home
Build 17134 .rs4_release.180410-1804

This Asus system was running fine (access to MSS ok) on 5/25/18, now have this error/access condition upon return from Vacation 6/22/18 and powering on MSS.

Checking windows updates shows both systems receiving 1803 Cum update (KB4284835) mid June. Both systems are running auto windows update.

Any ideas?

_________________
EX495
WHSV1


Top
 Profile  
Thanks  
PostPosted: Sun Jun 24, 2018 11:18 am 
Offline
1.5TB storage
1.5TB storage

Joined: Tue Oct 01, 2013 12:06 am
Posts: 64
Thanks: 10
Thanked: 2 times in 2 posts
This Asus client does not have SMBv1.0 enabled in windows features.

Can't find the same controls in WHSV1 (advanced admin)…?

Most sites I have read state that I cannot upgrade WHSv1 above SMBV1. That I would need to upgrade the server OS to something higher that integrates better SMB versions. What might be good upgrade target for WHSV1?

After reading articles about security risks of SMB1, it seems? that WHSV1 is not where I need to be... Thoughts?

_________________
EX495
WHSV1


Top
 Profile  
Thanks  
PostPosted: Sun Jun 24, 2018 11:49 am 
Offline
1.5TB storage
1.5TB storage

Joined: Tue Oct 01, 2013 12:06 am
Posts: 64
Thanks: 10
Thanked: 2 times in 2 posts
Tried to map a new network connection to MSS, got same SMB error....

_________________
EX495
WHSV1


Top
 Profile  
Thanks  
PostPosted: Sun Jun 24, 2018 12:11 pm 
Offline
1.5TB storage
1.5TB storage

Joined: Tue Oct 01, 2013 12:06 am
Posts: 64
Thanks: 10
Thanked: 2 times in 2 posts
ok, found this in the detailed "whats included in this KB" I mentioned above: (sorry, it does not format well)

Known issues in this update

Some users running Windows 10 version 1803 may receive an error "An invalid argument was supplied" when accessing files or running programs from a shared folder using the SMBv1 protocol.

Symptom Workaround:

Enable SMBv2 or SMBv3 on both the SMB server and the SMB client, as described in KB2696547.
Microsoft is working on a resolution that will be available later in June.

here is link to that KB Detail:

https://support.microsoft.com/en-us/hel ... -kb4284835

_________________
EX495
WHSV1


Top
 Profile  
Thanks  
PostPosted: Sun Jun 24, 2018 1:13 pm 
Offline
1.5TB storage
1.5TB storage

Joined: Tue Oct 01, 2013 12:06 am
Posts: 64
Thanks: 10
Thanked: 2 times in 2 posts
Uninstalled the subject KB and the SMB problem did NOT go away... AARRGGHH

_________________
EX495
WHSV1


Top
 Profile  
Thanks  
PostPosted: Sun Jun 24, 2018 5:45 pm 
Offline
1.5TB storage
1.5TB storage

Joined: Tue Oct 01, 2013 12:06 am
Posts: 64
Thanks: 10
Thanked: 2 times in 2 posts
Unable right now to roll back off of 1803.... I uninstalled all other 1803 os updates with no Joy...

_________________
EX495
WHSV1


Top
 Profile  
Thanks  
PostPosted: Mon Jun 25, 2018 9:25 am 
Offline
Max Contributor
Max Contributor

Joined: Tue Jan 05, 2010 9:29 am
Posts: 1171
Thanks: 5
Thanked: 144 times in 143 posts
I just looked at my desktop which I installed the os on.
win10 home 64bit. About 10 months ago

It only has smb1.0 installed.

And of course I don't have the issue.
And I have updates turned on.

_________________
EX-490
WHS v1
VGA/PS2 Keyboard/PS2 Mouse/Serial debug board
Q9450s CPU
Stock Ram
ESATA Sansdigital Towerraid TR5M-B
Popcorn C-200
Popcorn A-200
Dune HD Connect
Rasberry PI OSMC(KODI)
ReadyNAs RN316


Top
 Profile  
Thanks  
PostPosted: Mon Jun 25, 2018 9:43 am 
Offline
1.5TB storage
1.5TB storage

Joined: Tue Oct 01, 2013 12:06 am
Posts: 64
Thanks: 10
Thanked: 2 times in 2 posts
Thanx Ruben, yes why one fails and one works is a conundrum...

I found this additional message that speaks to WHSV1, it includes some additional workarounds... trying now....
https://answers.microsoft.com/en-us/win ... 5c5a52489f

_________________
EX495
WHSV1


Top
 Profile  
Thanks  
PostPosted: Mon Jun 25, 2018 10:12 am 
Offline
1.5TB storage
1.5TB storage

Joined: Tue Oct 01, 2013 12:06 am
Posts: 64
Thanks: 10
Thanked: 2 times in 2 posts
Following the link above recommendation to turn SMB1 on via "Windows Features" solved my current issue. But it seems more like a temporary workaround.

Is a 2008R2 upgrade of my WHSV1 a proper next step to get to SMB2? Does my EX495 have the power to do that (I have made no hardware upgrades to it).

_________________
EX495
WHSV1


Top
 Profile  
Thanks  
PostPosted: Mon Jun 25, 2018 10:25 am 
Offline
1.5TB storage
1.5TB storage

Joined: Tue Oct 01, 2013 12:06 am
Posts: 64
Thanks: 10
Thanked: 2 times in 2 posts
Attachment:
SMB1 Workaround.pdf [212.24 KiB]
Downloaded 10 times

_________________
EX495
WHSV1


Top
 Profile  
Thanks  
PostPosted: Mon Jun 25, 2018 4:48 pm 
Offline
1.5TB storage
1.5TB storage

Joined: Sun May 19, 2013 9:40 pm
Posts: 73
Thanks: 13
Thanked: 2 times in 2 posts
I just today worked thru this issue myself. Funny to see it posting here so quickly. Windows 10 fall update 1709 appears to have SMB1 enabled by default, but the Spring 2018 (1803 update on a new terminal I'm just now replacing did not. So you are correct that you have to go into windows features to enable it. But I am sure the time is coming when it will no longer be included in Microsoft desktop software.

I also read something from Microsoft on it that if you do a fresh install of 1803 and do not use SMB1 within 15 (45?) days of activation it will uninstall (or maybe it was deactivate) itself.

As far as updating WHS V1 to the newer protocol, There might be a server 2003 update for it that you could manually push. If you can find it please post.

As to WHS11, my guess is it already runs v2.0 since it is based on server 2008.


Top
 Profile  
Thanks  
PostPosted: Mon Jun 25, 2018 8:51 pm 
Offline
1.5TB storage
1.5TB storage

Joined: Tue Oct 01, 2013 12:06 am
Posts: 64
Thanks: 10
Thanked: 2 times in 2 posts
Thanx Lion, good info, I'll keep looking.. But not hopeful about WHSV1 smb fix... I would feel better being off SMB1...

Don't I have to upgrade WHSV1to WHS2008 first, then can upgrade to 2011?

Is there a Upgrade instruction thread here somewhere? I looked thru software and did not see?

_________________
EX495
WHSV1


Top
 Profile  
Thanks  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 23 posts ]  Go to page 1, 2  Next

All times are UTC - 7 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group