It is currently Mon Nov 11, 2019 6:19 pm

All times are UTC - 7 hours [ DST ]

Recent News:



Post new topic Reply to topic  [ 7 posts ] 
Author Message
PostPosted: Thu Feb 10, 2011 6:02 pm 
Offline
1TB storage
1TB storage

Joined: Thu Feb 10, 2011 5:16 pm
Posts: 42
Location: Houston, TX
Thanks: 5
Thanked: 0 time in 0 post
Hello everyone. I’ve been debating between expanding my system via USB expansion boxes (esata already used) or building my own, and despite the fact that it’s over 6x the cost, I think I want to DIY a new WHS, especially after reading about several users' builds on here. I see that Newegg has “deactivated” the TR8U enclosures, and even Sans Digital shows the TR8U-B as discontinued (leaving only the silver). While I'm not a novice at building pc's (have built my last 3), I've never taken on a large project like this or dealt with SAS cards, multiple NICs, etc. But what the heck, it’s only money, blood, sweat, and tears, right?

That said, I’ve read through some threads, tried to understand a few things, and have come up with a tentative build list and a few questions. Nothing fancy for me here, just planning to use JBOD and let WHS DE do its thing (trying to keep it simple, stupid). First, the initial specs:

Case Norco RPC-4220
Motherboard Supermicro X8ST3-F
CPU Intel Core i7-950
RAM 4GB, 240 pin, DDR3 PC3-8500 (CT51272BA1067)
SAS Cards Supermicro AOC-SASLP-MV8 (3)
Power Supply Corsair HX750
BD Drive LG CT21N
OS Drive Scorpio Black 500GB
OS Windows Home Server Power Pack 3
Cables (5) 1.64 feet Norco C-SFF8087-D SAS cable
Storage Drives (20) 2TB drives
UPS Existing APC J10?

And yes, I know the processor is overkill for WHS, but it a good selection for the board, which is one that is really nice and recommended for this type of build by at least one of you. Now onto the questions:

(1) Anyone see any concerns with the components chosen above (preferences aside, I’m only interested in hearing about “real” problems - such as "that board won't work", "your power supply is inadequate", etc.)?

(2) I recall reading on one of the threads (or on another forum) that one user was able to flash his Supermicro board to allow JBOD on the SAS or SATA ports (instead of raid). Can someone confirm this is possible? That might save me a SAS card, but if not, it’s only $110. Part of me wants to only use the onboard ports for OS drive and BD drive anyway to avoid any potential issues. Any thoughts on one way or the other?

(3) Did I read correctly somewhere that the SAS cards require a floppy to install the drivers? I’m sorry, I’ve read so much over the last 3 days that my mind is a fog with all the data in it. Just trying to nail down all the potential issues with this build and layout the plan ahead of time.

(4) I’ve also read about slipstreaming the SAS board drivers to make a server recovery disk. I know what slipstreaming is, I’ve never done it and really don’t want to get into it (yes, I’m chicken – I’m a CPA, not a Server Admin). Would I be as safe regularly backing up the OS drive to another drive, or setting up a RAID array for the OS drive (2-500gb drives)? Or will I need to do the slipstream regardless? I plan to keep the EX470 for pc backups, photos, music and dedicate the new build to video only - would it be possible to backup the new WHS to the EX470 like a regular pc? That way I could "restore" from the EX470 in case of a failure.

(5) Finally, I have an APC J10 in the designated a/v rack (1 of 2) that is supporting a dvr, Aviatrix whole house component distribution system, and a Nuvo whole house audio system. There are also 3 Sony megachangers tied into it, but they are coming out when the WHS goes in. Any thoughts on whether the J10 would be sufficient as a power conditioner/battery backup? I know, it’s not server grade, and I wouldn’t have the nice features such as remote access, just thinking about cost at the moment. If not, can you recommend a good APC (or other brand) rack mount UPS to use with the WHS?

Thanks in advance everyone. I'm sure I'll have more questions, but these are the ones I've accumulated to date. I've learned a lot from many of you over the last few days of reading and appreciate any help/feedback you can give.

_________________
HP EX470, WHS1, 2GB ram, 16.2TB storage (production - moving to decommissioned end of 2013)

Norco 4220, Supermicro board/SAS cards, 4GB ram, WHS 2011, Stablebit DrivePool, 64tb storage (production)


Top
 Profile  
Thanks  

Attention Guest: Remove this ad by Registering with the MediaSmartServer.net Forums. It's Free!
PostPosted: Thu Feb 17, 2011 9:49 pm 
Offline
Founder
Founder
User avatar

Joined: Tue Jul 31, 2007 11:54 am
Posts: 10704
Location: Fort Collins, Colorado
Thanks: 622
Thanked: 920 times in 875 posts
I've not done a massive build but nothing is jumping out on that list as problems, especially if you based it off of others success stories. I also can't answer all your questions about the Supermicro board or cards but can help with the WHS-specific ones.

3) Any card/storage controller that needs additional drivers added will need a floppy to install them. It's unfortunate but a reality due to the way server 2003 works. I built the images on the EX470 and had to load the SiS drivers every time. :( I also found some USB floppy drives to be flaky and not work, the cheap ones worked better than the fancy Sony ones.

4) You can look at the X-Files install images that Drashna from WeGotServed has built, he slipstreams some additional drivers in and they may work for you. You can't backup the OS and restore it, unfortunately, however you can RAID 1 (mirror) the OS drive if you'd like. Unfortunately WHS can't backup to WHS so you won't be able to use your EX470 that way. It'll continue to work great for PC backups, that's a good strategy you've got.

I hope that helps at least a little, and welcome to the forums!

_________________
Alex Kuretz
Remote Notification: Monitoring and alerting for your Home Server via email, Twitter, text message, RSS, push notifications, and on your Mac desktop
Have you tried our Add-Ins?


Top
 Profile  
Thanks  
PostPosted: Thu Feb 17, 2011 10:28 pm 
Offline
1TB storage
1TB storage

Joined: Thu Feb 10, 2011 5:16 pm
Posts: 42
Location: Houston, TX
Thanks: 5
Thanked: 0 time in 0 post
(3) Thanks for that. I'll pickup a cheap usb floppy at Microcenter or Frys this weekend. I still don't have a great understanding of the issue (I need to read some more), so I'm guessing that even if I were to wait to install the cards after installing WHS, I'd still need the floppy? (i.e., it won't install from the cd/bd drive)? My cards will only support the pool drives, so I could theoretically install them AFTER I get the entire system up and running.

(4) Yep, that's what I was afraid of. Oh well, the OS drives are not expensive (relatively) so I'll just buy a second and set them up in RAID 1. I need to go find the X-Files install images you refer to.

Appreciate the feedback, especially since I've already ordered everything (ok, so I'm anxious to get going)!! :D

Planning the build for next weekend (everything should be in early next week).

_________________
HP EX470, WHS1, 2GB ram, 16.2TB storage (production - moving to decommissioned end of 2013)

Norco 4220, Supermicro board/SAS cards, 4GB ram, WHS 2011, Stablebit DrivePool, 64tb storage (production)


Top
 Profile  
Thanks  
PostPosted: Fri Feb 18, 2011 8:58 am 
Offline
Founder
Founder
User avatar

Joined: Tue Jul 31, 2007 11:54 am
Posts: 10704
Location: Fort Collins, Colorado
Thanks: 622
Thanked: 920 times in 875 posts
The floppy is needed for the text-mode install portion of WHS that occurs after the first reboot when installing WHS.

_________________
Alex Kuretz
Remote Notification: Monitoring and alerting for your Home Server via email, Twitter, text message, RSS, push notifications, and on your Mac desktop
Have you tried our Add-Ins?


Top
 Profile  
Thanks  
PostPosted: Mon Mar 07, 2011 2:01 pm 
Offline
1TB storage
1TB storage

Joined: Thu Feb 10, 2011 5:16 pm
Posts: 42
Location: Houston, TX
Thanks: 5
Thanked: 0 time in 0 post
Status Update:

Progress is slow because I only have about 1 day a week to really devote to this (Saturdays).

All hardware has been installed and machine boots into BIOS. Wow, I really wish I'd known just how many molex connectors that case has - had to use some sata to molex adapters with my power supply as not enough molex cables/connectors. I have configured the RAID in BIOS and and used Cntrl+I during boot to setup the OS Raid 1 array.

Holy Jet Engines Batman! I thought all you guys were being melodramatic about the Norco case fans' noise. I thought I was standing on the Tarmac behind a 747 readying for takeoff! I definitely will need to work on upgrading the fans before I finalize the build, but wow. . .

I spent some time yesterday (was able to free up) working on the OS install. I tried using the normal install disk with my drivers on usb floppy. Unfortunately, due to the RAID setup, the install crashes before it even gets to a prompt for drivers (which apparently is common because WHS doesn't have the RAID drivers built in). So, I made a slipstreamed install disk using "less than optimal" instructions found on the MS forum. It installed, but I only got Win Server 2003, NOT WHS (even though the install came up saying that). When I logged in, I didn't have the WHS Console and couldn't find it in an executable anywhere. I ASSUME that my install was bad/incomplete.

So. . .next weekend I will enjoy CORRECTLY building a slipstreamed install disk using the wegotserved wiki instructions. If that doesn't work, I will back off the RAID setup and just do a simple install using the OEM disk. If I can't make RAID work on the OS, worst case scenario is that I have a spare OS drive (the raid 1 mirror drive) mounted in the case (unattached/unpowered) as a backup in case the single OS drive dies. I can swap connectors and do a server reinstall.

Quick install question: My OS drive(s) are connected to the motherboard. ALL of the data drives are connected via SAS cards and 4 SAS ports on the motherboard. For installation purposes, IF I have to go IDE (single OS drive), I'm thinking I don't need to install ANY drivers during OS installation (because it only needs access to the mobo SATA ports for installation). I should be able to install the SAS card and mobo drivers AFTER WHS is installed, right?

_________________
HP EX470, WHS1, 2GB ram, 16.2TB storage (production - moving to decommissioned end of 2013)

Norco 4220, Supermicro board/SAS cards, 4GB ram, WHS 2011, Stablebit DrivePool, 64tb storage (production)


Top
 Profile  
Thanks  
PostPosted: Mon Mar 14, 2011 12:53 pm 
Offline
1TB storage
1TB storage

Joined: Thu Feb 10, 2011 5:16 pm
Posts: 42
Location: Houston, TX
Thanks: 5
Thanked: 0 time in 0 post
SUCCESS!!! The new server (RED5) is up and running with the OS installed on a RAID1 array. I followed the wiki on slipstreaming at wegotserved and everything went smoothly. RED5 won't go into "production" for a while yet, until it has been thoroughly tested and is known to be stable, and a server reinstall has been tested. I loaded up a few add-ins over the weekend, and the only one that really didn't work was Home Server Smart, but I expected that because of my SAS setup; I removed it for now until further development on SAS support is done. Everything else is quite zippy, since I've got lots of unused horsepower in my cpu. I also could browse it from my Dune, and play the test media that I loaded on the data pool. Everything seems to be working fine.

The only problem I've run into is the bottom backplane is not being recognized. This is the only backplane I have plugged directly into the motherboard, so now I have to go about debugging - is it the backplane, the breakout cable, or the ports/driver on the motherboard. Worst case is I will add another SAS card to the mobo and use a SAS cable connector. I tested a drive in every slot of the other 4 backplanes and each slot was recognized, so that's good to know (given others' history with Norco case issues).

I've also ordered 4 replacements fans from Newegg yesterday. Hopefully they will help quieten it down a bit. It is currently on a table upstairs on one end of my house, and I could hear it from the kitchen downstairs on the other end of my house!!!

_________________
HP EX470, WHS1, 2GB ram, 16.2TB storage (production - moving to decommissioned end of 2013)

Norco 4220, Supermicro board/SAS cards, 4GB ram, WHS 2011, Stablebit DrivePool, 64tb storage (production)


Top
 Profile  
Thanks  
PostPosted: Mon Mar 14, 2011 1:37 pm 
Offline
Founder
Founder
User avatar

Joined: Tue Jul 31, 2007 11:54 am
Posts: 10704
Location: Fort Collins, Colorado
Thanks: 622
Thanked: 920 times in 875 posts
Awesome, glad you got it running, thanks for sharing the update. :mss:

_________________
Alex Kuretz
Remote Notification: Monitoring and alerting for your Home Server via email, Twitter, text message, RSS, push notifications, and on your Mac desktop
Have you tried our Add-Ins?


Top
 Profile  
Thanks  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 

All times are UTC - 7 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group