It is currently Tue Dec 11, 2018 9:27 pm

All times are UTC - 7 hours [ DST ]

Recent News:



Post new topic Reply to topic  [ 14 posts ] 
Author Message
PostPosted: Sun Oct 19, 2008 10:40 am 
Offline
1.5TB storage
1.5TB storage
User avatar

Joined: Thu Jan 24, 2008 12:08 am
Posts: 59
Location: Wexford, PA (USA)
Thanks: 6
Thanked: 0 time in 0 post
For all I know, this may have been a problem with the old version of the forum as well, but I recently developed a problem with my MSS and tried to search the forum to see if I could find the same or similar problem, and the search dropped several of my search terms as being too common. This left me with a completely useless search. (I believe the search term in question was "backup", which was the most important term in my search; I was trying to find posts about a backup that was seemingly taking forever. For what it's worth, I determined the problem was with my client computer's hard drive and ordered a new one.)

Just now, I tried to find any posts about Windows Desktop Search 4.0, and the search dropped "desktop", "windows", and "4". Am I doing something wrong (like missing an advanced search option somewhere)? I don't seem to be able to search on an exact phrase. (I would use Google to search the site if I remembered how, but ever since I started using Firefox, I've used the search bar to search on Google and just about every other site I search regularly, so I've forgotten all the advanced Google options.)

If it's not user error on my part and there's something odd about the forum's search function, then you might be getting extra posts due to someone thinking they've done a thorough search, not finding anything useful in the first page of posts, and starting a new post on a topic that actually *was* there. (I'm envisioning questions that wind up getting asked and answered multiple times because the search feature drops the terms that would make them stand out in the search results.)

Kira


Top
 Profile  
Thanks  

Attention Guest: Remove this ad by Registering with the MediaSmartServer.net Forums. It's Free!
PostPosted: Sun Oct 19, 2008 11:03 am 
Offline
ubermensch

Joined: Sun Apr 20, 2008 2:43 pm
Posts: 750
Thanks: 3
Thanked: 3 times in 1 post
You should PM Yakuza about that, he is the only one (I believe) who has any control over the search functions. I have run into that problem as well.

_________________
This Space For Rent


Top
 Profile  
Thanks  
PostPosted: Sun Oct 19, 2008 4:18 pm 
Offline
1.5TB storage
1.5TB storage
User avatar

Joined: Thu Jan 24, 2008 12:08 am
Posts: 59
Location: Wexford, PA (USA)
Thanks: 6
Thanked: 0 time in 0 post
Thanks, jd33308. I'm glad I'm not the only one who's noticed it.


Top
 Profile  
Thanks  
PostPosted: Sun Oct 19, 2008 4:54 pm 
Offline
Moderator
Moderator
User avatar

Joined: Fri Dec 07, 2007 11:18 pm
Posts: 539
Location: Orange County, CA
Thanks: 2
Thanked: 14 times in 13 posts
kira13 wrote:
For all I know, this may have been a problem with the old version of the forum as well, but I recently developed a problem with my MSS and tried to search the forum to see if I could find the same or similar problem, and the search dropped several of my search terms as being too common. This left me with a completely useless search. (I believe the search term in question was "backup", which was the most important term in my search; I was trying to find posts about a backup that was seemingly taking forever. For what it's worth, I determined the problem was with my client computer's hard drive and ordered a new one.)

Just now, I tried to find any posts about Windows Desktop Search 4.0, and the search dropped "desktop", "windows", and "4". Am I doing something wrong (like missing an advanced search option somewhere)? I don't seem to be able to search on an exact phrase. (I would use Google to search the site if I remembered how, but ever since I started using Firefox, I've used the search bar to search on Google and just about every other site I search regularly, so I've forgotten all the advanced Google options.)

If it's not user error on my part and there's something odd about the forum's search function, then you might be getting extra posts due to someone thinking they've done a thorough search, not finding anything useful in the first page of posts, and starting a new post on a topic that actually *was* there. (I'm envisioning questions that wind up getting asked and answered multiple times because the search feature drops the terms that would make them stand out in the search results.)

Kira



I have tried to search Windows Desktop Search 4.0

both logged in and as a guest, both work fine. So either it is your user type or on your end. I will PM Alex and see if he can look into it.

_________________
If you only have 1 copy of a file you do not have a copy! Back-up off site!!!
If someone wrote a particularly helpful post? Use the "Thank Post" button!


Top
 Profile  
Thanks  
PostPosted: Mon Oct 20, 2008 10:55 am 
Offline
Founder
Founder
User avatar

Joined: Tue Jul 31, 2007 11:54 am
Posts: 10690
Location: Fort Collins, Colorado
Thanks: 622
Thanked: 915 times in 871 posts
Very strange, I just did some testing and see what you mean. The search does not exclude the common terms if you are logged in as a guest or Moderator, but does for general users. There is a setting for "Common word threshold" that says a search term is ignored if it exists in x% of posts, this defaults to 20%. I have disabled this feature since our board is fairly limited in scope of topics. It may take up to an hour or so for that search term to expire from the cache.

_________________
Alex Kuretz
Remote Notification: Monitoring and alerting for your Home Server via email, Twitter, text message, RSS, push notifications, and on your Mac desktop
Have you tried our Add-Ins? If so, be sure to Rate them at WeGotServed.


Top
 Profile  
Thanks  
The following user would like to thank yakuza for this post
kira13
PostPosted: Sat Oct 25, 2008 9:39 am 
Offline
1.5TB storage
1.5TB storage
User avatar

Joined: Thu Jan 24, 2008 12:08 am
Posts: 59
Location: Wexford, PA (USA)
Thanks: 6
Thanked: 0 time in 0 post
Thanks for checking and fixing!

(I can see why "backup" would have been dropped with that rule.)


Top
 Profile  
Thanks  
PostPosted: Sat Oct 25, 2008 9:48 am 
Offline
1.5TB storage
1.5TB storage
User avatar

Joined: Thu Jan 24, 2008 12:08 am
Posts: 59
Location: Wexford, PA (USA)
Thanks: 6
Thanked: 0 time in 0 post
Hmm, just retried my "slow backup" search (because the new hard drive that I spent this past week ordering, waiting for, and installing did not fix it after all), and it still drops "backup". I think (judging by the dates, and assuming I'm not caught in a time warp) it's been more than "an hour or so" since your fix.

I will just check the latest troubleshooting posts and then ask my question, I guess, but wanted to report here in case something is still oddly configured.


Top
 Profile  
Thanks  
PostPosted: Sat Oct 25, 2008 1:35 pm 
Offline
Founder
Founder
User avatar

Joined: Tue Jul 31, 2007 11:54 am
Posts: 10690
Location: Fort Collins, Colorado
Thanks: 622
Thanked: 915 times in 871 posts
Ok, I just dropped the entire search index and am rebuilding it, with the zero commonality rule in place. If this doesn't fix the search issue, I don't know what will. It will probably be a couple hours before the index rebuild completes.

_________________
Alex Kuretz
Remote Notification: Monitoring and alerting for your Home Server via email, Twitter, text message, RSS, push notifications, and on your Mac desktop
Have you tried our Add-Ins? If so, be sure to Rate them at WeGotServed.


Top
 Profile  
Thanks  
PostPosted: Sun Oct 26, 2008 1:34 am 
Offline
1.5TB storage
1.5TB storage
User avatar

Joined: Thu Jan 24, 2008 12:08 am
Posts: 59
Location: Wexford, PA (USA)
Thanks: 6
Thanked: 0 time in 0 post
I'll try my search again later (just to give it enough time, although from what you said it should be done by now) and see if it finds my own new post, then.

Sorry for all the trouble.

Kira


Top
 Profile  
Thanks  
PostPosted: Sun Oct 26, 2008 7:37 pm 
Offline
1.5TB storage
1.5TB storage
User avatar

Joined: Thu Jan 24, 2008 12:08 am
Posts: 59
Location: Wexford, PA (USA)
Thanks: 6
Thanked: 0 time in 0 post
Tried it just now and it worked! Yay! Thanks again, yakuza!

Kira


Top
 Profile  
Thanks  
PostPosted: Mon Oct 27, 2008 2:14 pm 
Offline
Founder
Founder
User avatar

Joined: Tue Jul 31, 2007 11:54 am
Posts: 10690
Location: Fort Collins, Colorado
Thanks: 622
Thanked: 915 times in 871 posts
Thanks for the detailed info to find the problem! :)

_________________
Alex Kuretz
Remote Notification: Monitoring and alerting for your Home Server via email, Twitter, text message, RSS, push notifications, and on your Mac desktop
Have you tried our Add-Ins? If so, be sure to Rate them at WeGotServed.


Top
 Profile  
Thanks  
The following user would like to thank yakuza for this post
kira13
PostPosted: Sun Feb 22, 2009 2:48 pm 
Offline
Newbie
Newbie

Joined: Thu Feb 12, 2009 3:35 pm
Posts: 4
Thanks: 0
Thanked: 0 time in 0 post
Hello, I have a problem with installing Add-Ins and I used the Search function to look for the word Add-Ins and got the reply: "No posts were found because the word add-ins is not contained in any post". Hmm, that doesn't seem right. Any ideas? Thanks!


Top
 Profile  
Thanks  
PostPosted: Sun Feb 22, 2009 8:11 pm 
Offline
Moderator
Moderator
User avatar

Joined: Fri Dec 07, 2007 11:18 pm
Posts: 539
Location: Orange County, CA
Thanks: 2
Thanked: 14 times in 13 posts
Sounds like an issue I just tried add-in and got nothing but tried add in and found posts with add-in. LOL :rofl:

_________________
If you only have 1 copy of a file you do not have a copy! Back-up off site!!!
If someone wrote a particularly helpful post? Use the "Thank Post" button!


Top
 Profile  
Thanks  
PostPosted: Sun Feb 22, 2009 9:18 pm 
Offline
Founder
Founder
User avatar

Joined: Tue Jul 31, 2007 11:54 am
Posts: 10690
Location: Fort Collins, Colorado
Thanks: 622
Thanked: 915 times in 871 posts
I guess it's the hyphen throwing off the search, it might be a reserved character in SQL. I have no clue how to fix that, so I guess you'll have to use COPC's workaround.

_________________
Alex Kuretz
Remote Notification: Monitoring and alerting for your Home Server via email, Twitter, text message, RSS, push notifications, and on your Mac desktop
Have you tried our Add-Ins? If so, be sure to Rate them at WeGotServed.


Top
 Profile  
Thanks  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 14 posts ] 

All times are UTC - 7 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group