It is currently Thu Jun 20, 2019 9:05 am

All times are UTC - 7 hours [ DST ]

Recent News:



Post new topic Reply to topic  [ 6 posts ] 
Author Message
PostPosted: Mon Jan 13, 2014 9:14 am 
Offline
.5TB storage
.5TB storage
User avatar

Joined: Sun Apr 24, 2011 7:51 am
Posts: 10
Location: UK
Thanks: 0
Thanked: 2 times in 2 posts
Over the weekend with some idle time for tinkering, i decided to upgrade the noisy old 250GB drive in my X510 for a spare 500GB Seagate Barracuda ES.2 I had in a drawer..... I have to admit it has been a while since I installed WHS so not sure if what I saw after a reinstall of WHS2011 is "normal" behaviour but the drive, a ST3500320NS, seemed to show up as a removable USB drive! :shock:

A look in the Device Manager also showed an error for a "Mass Storage Controller" in Other Devices. Surely can't be right I thought, and under "IDE ATA/ATAPI controllers" it showed just a "Standard AHCI Serial ATA Controller", no sign of the ICH9R I was sure it should have been there! It did not seem to be mentioned in the install guides I could find at the time (http://www.mediasmartserver.net/2010/04/26/how-to-install-windows-home-server-vail-on-the-hp-mediasmart-server/).

A fresh install from USB either headless or using Gen3 debug board as I did. Once complete it seems that the following two drivers also need to be installed:

Intel Rapid Storage Technology (Intel RST) RAID Driver
The latest version at the moment is v12.9.0.1001 (f6flpy-x64.zip)
http://www.intel.com/p/en_US/support/highlights/sftwr-prod/imsm

Silicon Image Sil3531 SATA Controller Driver
The latest version seems to be v1.5.20.1 (3531_x64_w7_1.5.20.1_logo.zip)
http://www.siliconimage.com/support/

A reboot after each one and the view from Device Manager of the controllers is much happier.
+ IDE ATA/ATAPI controllers
- Intel(R) ICH9R/D0/DH SATA AHCI Controller
+ Storage controllers
- Silicon Image Sil 3531 SATA Controller


Once the Windows Update process has completed the 150+ updates it finds, these are also well worth installing:

HP EX48x Lights Management Driver For WHS 2011
A working driver and service for the MediaSmart Server to allow the LEDs to function under Windows Home Server 2011.
http://www.mediasmartserver.net/2011/06/23/mediasmart-server-led-management-for-windows-home-server-2011/

Drive Bender
I also found that Drive Bender was on a 40% discount at the moment, so took them up on their generosity as it ends today!
It seems close run thing between Drive Bender and StableBit DrivePool, but the offer and better website clinched it.
http://www.drivebender.com/drive-bender-buy-sn

Hope this helps someone else suffering from brain fade while trying to rebuild their HP EX49x/X510 server! ](*,)

_________________
EX490 - Q8200S | 4GB | 6TB of Samsung
X510 - E8400 | 4GB | 6TB of Seagate

The cloud is for people with their heads in them!


Top
 Profile  
Thanks  

Attention Guest: Remove this ad by Registering with the MediaSmartServer.net Forums. It's Free!
PostPosted: Tue Jan 14, 2014 12:35 pm 
Offline
.5TB storage
.5TB storage
User avatar

Joined: Sun Apr 24, 2011 7:51 am
Posts: 10
Location: UK
Thanks: 0
Thanked: 2 times in 2 posts
I reread my notes and found I had given the wrong version of the RST driver. Link still fine.

It should be the AHCI driver found in this file - 10.8.0.1003_f6flpy-x64.zip - that installs to replace the standard SATA driver (shown in pic). All very exciting ahem :oops:


Attachments:
File comment: WHS2011 install gives a standard SATA driver, not correct one!
Device Manager SATA.jpg
Device Manager SATA.jpg [ 79.77 KiB | Viewed 5241 times ]

_________________
EX490 - Q8200S | 4GB | 6TB of Samsung
X510 - E8400 | 4GB | 6TB of Seagate

The cloud is for people with their heads in them!
Top
 Profile  
Thanks  
PostPosted: Sat Apr 02, 2016 4:51 am 
Offline
1.5TB storage
1.5TB storage

Joined: Wed Feb 12, 2014 2:49 pm
Posts: 65
Thanks: 3
Thanked: 0 time in 0 post
I've got the same issue. However, my CPU's an intel. Firstly, Silicon IMage seems no more - so have to grab 3531 drivers off archives. Secondly - in the inf file - all drivers I can find are for AMD chips. Mine's an Intel

Just wondering if anyone's got an intel one or whether it matters?

thanks


Top
 Profile  
Thanks  
PostPosted: Sun Apr 03, 2016 10:40 am 
Offline
Max Contributor
Max Contributor
User avatar

Joined: Sat Apr 12, 2008 12:49 pm
Posts: 2215
Location: Casper Wyoming
Thanks: 76
Thanked: 249 times in 246 posts
I have not used this driver, but looks like it should work. The x-510 is a intel cpu.

This from a google search: I make no guarantee:
http://www.drivers-download.com/en/downloadlist.php?id=72

If you do use it and it works, please let us know, might come in handy for others.....

P.S. I did some poking around and found this: http://www.latticesemi.com/view_document?document_id=51589
I had to create an login account to get to it, so don't know where this link will stop.

Good Luck


Attachments:
File comment: Looks like a driver
3531_x64_w7_15201_logo.zip [252.69 KiB]
Downloaded 145 times

_________________
[X510 CPU/RAM/All 2 TB Red's] [X510 CPU/Sync'ed Backup/All 2 TB Hitachi's]
[X510 /2 in box]
[X710 LIAN LI DIY W2012E] Stablebit Drivepool [EX-503 LIAN LI 5-bay USB3 External]
:twisted: Fear the Cloud :twisted:
Top
 Profile  
Thanks  
PostPosted: Sun Apr 03, 2016 1:29 pm 
Offline
1.5TB storage
1.5TB storage

Joined: Wed Feb 12, 2014 2:49 pm
Posts: 65
Thanks: 3
Thanked: 0 time in 0 post
Thanks. Things have since progressed. All my installation/update woes were being caused by dodgy ram. Fitted some working + now the 3531 drivers I'd sourced from various places seem to install OK (the readme just says it's for AMD, but maybe that's a generic readme).

So far so good...


Top
 Profile  
Thanks  
PostPosted: Wed Apr 06, 2016 7:54 am 
Offline
Max Contributor
Max Contributor
User avatar

Joined: Sat Apr 12, 2008 12:49 pm
Posts: 2215
Location: Casper Wyoming
Thanks: 76
Thanked: 249 times in 246 posts
Good to hear, good luck.... The wee little servers are not dead yet lololooll

_________________
[X510 CPU/RAM/All 2 TB Red's] [X510 CPU/Sync'ed Backup/All 2 TB Hitachi's]
[X510 /2 in box]
[X710 LIAN LI DIY W2012E] Stablebit Drivepool [EX-503 LIAN LI 5-bay USB3 External]
:twisted: Fear the Cloud :twisted:


Top
 Profile  
Thanks  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC - 7 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group