It is currently Tue Nov 29, 2022 8:27 am

All times are UTC - 7 hours [ DST ]

Recent News:



Post new topic Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Sat Sep 24, 2022 11:37 am 
Offline
Newbie
Newbie

Joined: Wed Sep 21, 2022 10:23 pm
Posts: 1
Thanks: 0
Thanked: 1 time in 1 post
Some notes from resurrecting my old EX475 for service as a backup server, committed here for posterity and perhaps my own future reference.

Highlights
    - 10TB WD Red drives were no problem. 4GB DDR2-6400 800MHz RAM works great. The single-core stock CPU is slow, but not totally unusable.
    - I had to change the SATA mode to IDE+IDE, and I had to disable "simplefb" so that the built-in SiS video would work.

Hardware
    Disks:
      4x 10TB WD Red (WD100EFAX)
      Detected without issue, large disks not a problem
    RAM:
      Hynix 4GB PC2-6400 DDR2 800MHz 2Rx8
      The system recognizes it as 800MHz
      Works great, much faster than the stock 512
      System sees only 3.25GB, not a big deal
    CPU:
      Stock AMD Sempron 3400+ single-core
    VGA cable
      Cable or debug adapter required for installation
      Found one on eBay
    USB thumb drive
      For booting the system

BIOS
    Stock BIOS, reset to defaults
    Integrated Peripherals > SiS OnChip PCI device > SiS Serial ATA mode: 4S(IDE)+4P(IDE) (both set to IDE)

Software
    Proxmox Backup Server 2.2

Procedure
    - Download the Proxmox Backup Server 2.2 iso installer from Proxmox and write it to your USB drive — procedure depends on your admin workstation
    - Connect a display to the server's VGA cable, and connect a keyboard to the front USB port of the server
    - Plug the USB drive into the lowermost rear USB port of the server
    - Power up the server
    - Press F12 repeatedly to call up the boot device menu
    - Select +HDD > <Your USB drive> to boot from the USB drive
    - The system will boot to the Proxmox installer.
    - At the install screen, before you select anything, press the 'e' key
    - Move the cursor to the line that begins with linux and add video=simplefb:off to the parameters. If you do not, you'll get a message that the video memory could not be allocated because another framebuffer is already active. Disabling the simplefb allows the SiS video to initialize. The result looks like this:
    Code:
    linux /boot/linux26 ro video=simplefb:off ramdisk_size=16777216 rw quiet splash=silent

    - Press F10 to boot.
    - The screen goes black for a minute or so, but then you should see the Proxmox EULA screen.
    - From here, it's business as usual to install Proxmox Backup Server.

Other considerations:
    - I opted for Raid-Z1.
    - ZFS works just fine without huge amounts of physical RAM.
    - The SiS chipset is kinda wonky but it works.
    - github.com/merelin/mediasmartserverd doesn't seem to recognize the LEDs in this chassis.
    - By all indications, performance is entirely constrained by the CPU. 5400RPM disks, slow SiS SATA, ethernet … none of this is being saturated, while the CPU is at 100% during transfers.
    - So far, this thing seems capable of backing up and restoring at a rate of about 15GB per hour. Not great, but once I get everything transferred the first time, incremental backups should go very quickly. Restoring an entire 20TB server is going to be a different story, one I hope not to have to tell.

One other thing: as I was reassembling my server and returning the exterior panels, I used a screwdriver to bend the metal tab on the top of the enclosure so that the top panel won't engage with it fully. This lets me slide the top panel off without removing the disk in the top slot, making it easier to access the VGA cable, which I secured with a rubber band so that it doesn't fall down into the chassis. Photo attached.


Attachments:
IMG_1993.jpg
IMG_1993.jpg [ 499.73 KiB | Viewed 1368 times ]
Top
 Profile  
Thanks  
The following user would like to thank jmbwell for this post
Banquo73

Attention Guest: Remove this ad by Registering with the MediaSmartServer.net Forums. It's Free!
PostPosted: Wed Sep 28, 2022 10:51 am 
Offline
1TB storage
1TB storage

Joined: Thu Aug 15, 2019 5:43 am
Posts: 35
Location: Leics, United Kingdom
Thanks: 12
Thanked: 6 times in 6 posts
Great post, thanks for sharing. So is Proxmox running off the flash disk the EX47x have or does it reside on one of the hard drives?

_________________
EX490
WHS v1
E5800
Stock Ram
HGST 1 x 2TB, 1 x 4TB, 2 x 8TB


Top
 Profile  
Thanks  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 7 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group