It is currently Fri Sep 25, 2020 5:33 pm

All times are UTC - 7 hours [ DST ]

Recent News:



Post new topic Reply to topic  [ 15 posts ] 
Author Message
 Post subject: WHS PP3, WMP11 & a PS3
PostPosted: Wed Aug 19, 2009 7:00 pm 
Offline
Newbie
Newbie

Joined: Sat Aug 15, 2009 12:03 pm
Posts: 8
Thanks: 2
Thanked: 0 time in 0 post
Hi!

I'm running WHS on an EX475 with the beta PowerPack 3 and I did the Windows Media Player 11 install/hack to use WMP11 to share media using the updated connector.

My PS3 is running the latest PS3 firmware (2.80) and it shows three separate instances of my HP EX475 MediaServer (why it shows-up three times I have no idea). Under the PS3 I can click on top level folders (e.g. Music) and then see the next level (by Artist, by Album, etc.) and when I pick "by Album" I do get a correct listing of albums on the MediaServer but if I pick any album, instead of a list of tracks I get "Image not available." Same goes for videos on the MediaServer, I can get the titles of the videos to display on the PS3 but when I choose one I get "Image not available." The funny thing is though the _real_ images (Photo folder) display perfectly!

Any ideas guys?

Thanks!

Chris R.


Top
 Profile  
Thanks  

Attention Guest: Remove this ad by Registering with the MediaSmartServer.net Forums. It's Free!
PostPosted: Fri Aug 21, 2009 9:00 am 
Offline
1.5TB storage
1.5TB storage

Joined: Sun Jun 07, 2009 7:28 am
Posts: 63
Thanks: 4
Thanked: 1 time in 1 post
Hi Chris,

I am going to be doing the WMP11 install per the page (once I find it again) and try getting my PS3 to play digital copies of movies from my WHS (I have the HP ex485 w/plenty of space available). I also picked up an external USB DVD burner for aiding in getting the movie(s) off the disc and onto the WHS itself and going thru the security crap we have to for enabling viewing of the movies once extracted.....so I'll try and post back once I get some time to work on this. See other thread about digital copies in this forum as well.

Mike


Top
 Profile  
Thanks  
The following user would like to thank metalmike for this post
crodgers79
PostPosted: Sun Aug 23, 2009 2:29 pm 
Offline
Newbie
Newbie

Joined: Sat Aug 15, 2009 12:03 pm
Posts: 8
Thanks: 2
Thanked: 0 time in 0 post
metalmike wrote:
Hi Chris,

I am going to be doing the WMP11 install per the page (once I find it again) and try getting my PS3 to play digital copies of movies from my WHS (I have the HP ex485 w/plenty of space available). I also picked up an external USB DVD burner for aiding in getting the movie(s) off the disc and onto the WHS itself and going thru the security crap we have to for enabling viewing of the movies once extracted.....so I'll try and post back once I get some time to work on this. See other thread about digital copies in this forum as well.

Mike



Hey Mike - THANKS!

I'm sorry for the late reply I was away on business last week. I just got around to working the issue again today (Sunday, August 23rd). I saw that one of the "Add-ins" on my WHS was "PV Connect" which is supposed to support/enhance media streaming.. it occurred to me that if I am to have WMP11 handle the media sharing then PV Connect may be interfering with it, trying to do the exact same function. I just removed PV Connect and rebooted the server and will check my PS3 later this evening to see if it made any difference. I have access to this forum from my work PC so I'll post another update tomorrow. Thanks again for your offer to help-out on this one!

With thanks,

Chris R.


Top
 Profile  
Thanks  
PostPosted: Sun Aug 23, 2009 3:08 pm 
Offline
1TB storage
1TB storage

Joined: Thu Mar 12, 2009 1:49 pm
Posts: 30
Thanks: 2
Thanked: 3 times in 3 posts
Guys,
For streaming movies to a PS3, I would recommend PS3 Media Streamer. You can find it here, http://ps3mediaserver.blogspot.com/ . It will take an ISO image and let you play it to your PS3. Great software and it is free....Works great with my WHC..


Top
 Profile  
Thanks  
The following user would like to thank Jcharmella for this post
crodgers79
PostPosted: Mon Aug 24, 2009 10:21 am 
Offline
Newbie
Newbie

Joined: Sat Aug 15, 2009 12:03 pm
Posts: 8
Thanks: 2
Thanked: 0 time in 0 post
Guys,

As i stated earlier, I removed the PV Connect add-in from my WHS, rebooted it and then Remote Desktop'd into the WHS and double-checked my WMP11 settings.. I went downstairs to the PS3 and Voila! everything works!! Yeah!! The only minor nit is that when you pick the category from the PS3 cross-bar (e.g. Music, Photos, Videos) you can see the corresponding folder on the WHS, which is great, but it will also list the other WHS folders (Video, Photo, Music) but the only folder which "works" is the one for the category corresponding to your pick in the cross-bar; meaning pick "Photos" in the cross-bar and the Photos display beautifully but the PS3 also shows Videos and Music as folders under "Photos" but they do not work; to view another category you just have to move the cross-bar to the corresponding category and it all matches one-for-one.

I must say that I'm impressed by the PS3s capability in this regard; it's fast, the backgrounds available during music play are cool and the animation used in the photo slideshow is top-notch! I, obviously, haven't tried streaming ripped DVDs, so let me know how you set that up on your end.

Thanks again,

Chris R.


Top
 Profile  
Thanks  
PostPosted: Wed Aug 26, 2009 6:51 pm 
Offline
1.5TB storage
1.5TB storage

Joined: Sun Jun 07, 2009 7:28 am
Posts: 63
Thanks: 4
Thanked: 1 time in 1 post
Hi Chris,

I followed all but the disabling of sharing from the WHS after installing WMP11. I get data type not supported message. I am also seeing a 3rd server, this one says Darkserver - Adminstrator which I went down into for video. I will see if the mp3's stream ok right now...The mp3's seem to be ok.

For servers on the PS3 I have:
Darkserver [TM]
Darkserver:1:Windows Media Connect
Darkserver: Administrator

Why am I seeing 3 of the same system? How can I clean that up (if needed)?

When I go into the top one I get no tracks available.
When I go into 2nd one I get network error 00000190
When I go into 3rd one I get unsupported data. That was the digital copy I extracted to my desktop PC and moved to the WHS. Do I need to a) delete the file and b) re-run the setup on the WHS from the external USB DVD burner I bought to extract it onto the WHS and then be able to play it across the network through this incarnation of the server? I don't want to have to find some good (free) ripping software that will take out the DRM stuff, I just want to be able to put the digital copies of movies onto my WHS and view them via the PS3 like I can for audio (or view it on any of my other PC's that connect to the WHS). Why is this such a pain in the backside?

Still frustrated on this video streaming piece. I don't want to have to rip the dvd's if I don't have to (and shouldn't if I can get the digital copy onto the WHS via USB DVD, that will work for me as long as I can play them across my local network).

Update: I can not access any music with the service turned off (per WMP11 install page) from the 3rd server, 2nd server is now gone due to sharing disabled and service stopped. I went into WMP->library->media sharing and i see unknown device (mac address is probably the PS3 as only this desktop and WHS is active (have one other but is a VM run from desktop). So the PS3 is the other mac address showing up. I have network secured down for the wireless side requiring password to get into it. So what am I missing here, if anything? I'm really getting frustrated at the pain that this is for digital copies of movies and now can't do mp3's unless I a) turn on service and b) enable sharing as the PS3 will then stream the audio fine.

Mike


Top
 Profile  
Thanks  
PostPosted: Thu Aug 27, 2009 4:59 am 
Offline
1.5TB storage
1.5TB storage

Joined: Sun Jun 07, 2009 7:28 am
Posts: 63
Thanks: 4
Thanked: 1 time in 1 post
Hi,

Ok, I re-read the directions and went into WMP11 and changed the configuration to be d:\shares\music\itunes and d:\shares\videos and am re-inventorying the files. We'll see if this now works. If it does with that movie (and can access my mp3's) I'll be happier. Otherwise I'll have to find some ripping software I may still have kicking around for the movies and try it that way. I'll post later this morning on results. I was using \\servername\directory UNC vs path info.

Mike


Top
 Profile  
Thanks  
PostPosted: Thu Aug 27, 2009 5:57 am 
Offline
1.5TB storage
1.5TB storage

Joined: Sun Jun 07, 2009 7:28 am
Posts: 63
Thanks: 4
Thanked: 1 time in 1 post
Well it isn't working for either mp3 or video playback, for mp3 says nothing in folders, for video says unsupported data type. I also got a DLNA Protocol error (7522) message earlier when I first tried this. I have the service stopped (windows media connect) on the WHS. What am I missing here?

I am about to give up on the video part and re-enable WMC on server and look for ripping software if someone can't help me out with this in more detail. I am on a wireless network connection to the PS3. I could run a cable to it for wired if that will improve things (for video specifically).

Mike


Top
 Profile  
Thanks  
PostPosted: Thu Aug 27, 2009 7:26 am 
Offline
Newbie
Newbie

Joined: Sat Aug 15, 2009 12:03 pm
Posts: 8
Thanks: 2
Thanked: 0 time in 0 post
Mike,

Keep in-mind that the source of my problem was an add-in (PV Connect). If you've got any other media sharing software installed, including PS3 streaming video software, I'd recommend removing it. My WHS was/is pretty-much a virgin installation since I just got my EX375 about 2 weeks ago. Also note that on my WHS I am running the Beta Power Pack 3 since all my home PCs are Win7 machines. I think Beta Power Pack 3 has improved PS3 support which may be why mine is working. You are correct in that in WMP11 you have to define the shares using drive letter\full path name and then reindex and usually after these things are completed I reboot the server; actually after every major modification (add/remove plug-ins, make changes, etc.) I reboot the server for good measure. I also set WMP11 to allow any newly discovered machines on my home network to automatically connect.

You _do_ have to disable Media Sharing on the WHS and you _also_ have to go into the Services console on the WHS and disable the Media Connect service. At first I was concerned about that but apparently the new Media Connector in WMP11 takes care of everything so if you left WHS Media Sharing "enabled" for Video, Music and Photos then you need to disable it - and then save your changes and reboot. That may be why you're seeing three instances of everything.

I get most of my movies on my Home Theater PC using Amazon.com's "Unbox" digital video service (no monthly fees, $2.99 rentals, immediate downloads, can play-back while downloading etc.) so I have no real need to rip DVDs to my WHS.

I would also add that I've spent some time tweaking my wireless router (Trendnet TEW-633GR) settings to support media streaming and have played with the antenna positioning to make sure that I'm getting maximum signal strength from it to my Trendnet Wireless n-Bridge that I use to connect both the PS3 and my Home Theater PC to the WHS which is on the second floor. I don't use wireless security I just MAC filtering to lock-down my network, that way there's no overhead associated with WEP or WPA2 encryption, although my wireless traffic is subject to sniffing since it's unencrypted traffic, but in the small town where I live my neighbors are lucky if they know how to drive, let alone sniff TCP packets, so I don't really worry about that too much.

I do still get some quirks - sometimes a video I stream to the PS3 one day will show up as "Unsupported" or "Corrupted Data" the next day.. I'm hoping the new Sony PS3 firmware (v.3.0) which I believe should be released any day now, may help with some of these problems.

Keep us all abreast of how you're making out.. my experience is that although it is only three of us participating in this thread, many more are actively following it.

Thanks!

Chris R.


Top
 Profile  
Thanks  
PostPosted: Thu Aug 27, 2009 8:26 am 
Offline
1.5TB storage
1.5TB storage

Joined: Sun Jun 07, 2009 7:28 am
Posts: 63
Thanks: 4
Thanked: 1 time in 1 post
Hi Chris,

I had disabled the service as said in the WMP11 installation webpage. I had rebooted the WHS at least twice today alone. I am not able to see my mp3's with it. I have Twonky and iTunes enabled. Should these be disabled? The reason I was using iTunes was because of my iPod obviously. It hosed my directories once since I had it set to manage and haven't gone back to try and salvage what it screwed up (thanks apple for crappy management software....) as it moved just about ALL my various artists\album name\tracks to artists\track which put more individual files onto the iTunes directory I created.

I just want to be able to use my USB DVD drive to install digital copies of blue-ray movies onto the WHS and view them via the PS3. How hard does this have to be? It is almost at the point I am not even going to bother with this *or* use dvd decrypter to rip the dvd's and move them onto the WHS (more work IMHO that route).

So, by following what the WMP11 install page said I was:
a) unable to view/play my mp3's
b) unable to view digital copy I had extracted to this desktop and copied over to the WHS, *but* since I have the DVD USB drive attached to it I may delete that movie and redo the digital copy onto the WHS and see what happens then. But see a) above, why am I now not able to stream mp3's to the PS3 in this fashion? Says no tracks available.

Mike


Top
 Profile  
Thanks  
PostPosted: Thu Aug 27, 2009 8:39 am 
Offline
Newbie
Newbie

Joined: Sat Aug 15, 2009 12:03 pm
Posts: 8
Thanks: 2
Thanked: 0 time in 0 post
Mike,

I think I'd remove both iTunes and Twonky and reboot and try it. Remember, the way I have it working I can only see my Music under the Music tab on the PS3 X-bar - if I choose "Video" on the PS3 X-bar I _still "see" all three shared folders on the WHS (Music, Photos, Video) but since I am looking on the "Video" part of the PS3 X-bar only the "Video" folder shows results from the WHS, the others (Music, Photos) show "No data" or a something similar. Also I don't know if you've tried installing the Beta Power Pack 3 for WHS but I'd recommend that as well if you haven't already tried it.

Chris R.


Top
 Profile  
Thanks  
PostPosted: Thu Aug 27, 2009 8:44 am 
Offline
1.5TB storage
1.5TB storage

Joined: Sun Jun 07, 2009 7:28 am
Posts: 63
Thanks: 4
Thanked: 1 time in 1 post
Hi,

Are you talking about uninstalling them or turning off the services for them? I'd have to figure out which files to move out from the addins directory first.

Also, what do you mean by X-bar? I scroll to my media server and see 2, one servername: TM (icon), other is servername:Administrator.

When I select the latter I get options for media types, I select video, it gives long listing (actor?, folders, all videos, etc...) and go to folders->videos->the hulk and get the message nothing found or whatever. Is this the path you are talking about for getting to the shares? I got the no files found under the music option from servername:administrator->music.

With regards to PP3 beta, maybe.


Top
 Profile  
Thanks  
PostPosted: Thu Aug 27, 2009 9:23 am 
Offline
Newbie
Newbie

Joined: Sat Aug 15, 2009 12:03 pm
Posts: 8
Thanks: 2
Thanked: 0 time in 0 post
Mike,

I'm no expert but I'd suggest uninstalling them from the Add-ins box of the WHS Console. You should _not_ manually remove any files, just uninstall it from the Add-ins tab on the WHS Console or use Remote Desktop and remote in to the WHS and use Control Panel Add/Remove Programs and find those programs and choose "Uninstall."

When I use the term "X-bar" it's short for "cross-bar" as-in the Sony PS3 interface, which is officially known as the "Media Cross-bar." Just like the Xbox 360 interface is call NXE for New User EXperience.

On the PS3 you should choose the servername:Administrator icon as that is the one provided by the WMP11 Connector.

The "path" I was talking about is in the WMP11 sharing tab where you tell it what folders to monitor; I think you already know that you can't use \\servername\share in that box, you have to use drivename:\path (e.g. D:\video)

I'd like to help you more but I'm at work today and this weekend is chock-full of activities.. I'll try and check back later though..

Chris R.


Top
 Profile  
Thanks  
PostPosted: Thu Aug 27, 2009 10:51 pm 
Offline
1.5TB storage
1.5TB storage

Joined: Sun Jun 07, 2009 7:28 am
Posts: 63
Thanks: 4
Thanked: 1 time in 1 post
Do you know which of the MSI/exe files I need to move out of the area for iTunes and whatnot? I see the PV* file but can't tell for twonky or iTunes at this point. If I can move those out of the addins directory I will have an easier time reinstalling them later as needed/if needed. I wish the programmers would make the names more related to the programs themselves. I had to guess for the stupid mcafee one to move it out of there.

But I did deinstall MyMovies (had issue with sql server service NOT starting no matter what I tried AND it was complaining about D:\Windows\Temp and other directories which is NOT where the database(s) are...so I had to do RDP for the SQL/C++ stuff and all seems ok atm. I just want to get this streaming going. If I have to use my USB DVD drive to get the digital copies onto the WHS and then move them or point to the videos directory and associated subdir (for sake of ease of management, i.e. Hulk, IronMan, etc...) I will be ok with that...I also snagged DVDDecrypter (which may not work on newer movies) just in case I go back to iTunes/Twonky/services running and put them in their respective directories down the road. I just wanted this to be as painless as possible. I also don't have access to PP3 (seems beta ended end of july for the latest release of it) so can't add that in either. I also don't have my WHS backed up as a system to external atm either....so I am leary of doing that in case I have to do a restore of sorts if things go south really bad.

What I want is:
a) stream mp3's from WHS to any of my PC's
b) stream mp3's from WHS to my PS3 if I choose to fire it up + my stereo/av setup
c) stream digital copies of movies (blue-ray 2nd DVD disc) to PS3 to my stereo/av setup
d) rip DVD's to be able to stream them from WHS to PS3 to my stereo/av setup

Is that too much to ask lol?!

Thanks for input/assistance (from anyone who can help me/us here!).

Mike


Top
 Profile  
Thanks  
PostPosted: Thu Sep 10, 2009 9:04 pm 
Offline
1.5TB storage
1.5TB storage

Joined: Sun Jun 07, 2009 7:28 am
Posts: 63
Thanks: 4
Thanked: 1 time in 1 post
So no feedback/input on this yet? Been a few weeks now. I'm starting to look at DVDFab as an alternative to running WMP on it since I have yet to get an answer to my previous post as to what addins to uninstall (via filename so I know what to possibly move out of the install directory so it doesn't show me that I have stuff to install but that's a minor point, but it'd be good info to know).

I haven't gotten back to this since the last post as I haven't had the time and was waiting on a reply to my last posts questions.

I may go DVDFab and forget WMP11 seeing it appears to be more of a pain than worth getting to work without more input/explanations on stuff.

Thanks,

Mike


Top
 Profile  
Thanks  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 15 posts ] 

All times are UTC - 7 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 7 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group