It is currently Wed Oct 23, 2019 2:26 pm

All times are UTC - 7 hours [ DST ]

Recent News:



Post new topic Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Mon Jul 11, 2011 8:35 pm 
Offline
1.5TB storage
1.5TB storage

Joined: Tue Dec 22, 2009 9:08 am
Posts: 58
Thanks: 2
Thanked: 5 times in 5 posts
I recently decided to ditch Twonky on my 495 due to a various annoyances and install PS3MediaServer. I only stream to my PS3 so it seemed like a good option (especially given that it transcodes on the fly). I got PS3MS working, but there was a small trick required that I didn't find in my initial googling, so I thought I'd pass it along.

I wanted "set it and forget it" (i.e. non-wife-annoying) workflow, so I wanted it to just run on it's own when the server boots up, I didn't want to have to log in with Remote Desktop and run it manually... In other words I wanted it run as a service. I figured I could configure it manually rather than using the "Any service installer" add-in.

The short version is that the "run as a service" executable is different than the "run it manually" executable and you have to unblock both in Windows firewall to get the service to work.

Long version:

I copied the installer to the WHS, then installed it via Remote Desktop.

I ran the program manually, which generated a Windows firewall "this program has been blocked message", so I unblocked it, then I configured PS3MS. For some reason it didn't find the NIC by default so I had to select it from a pull-down box. I also needed to change the default port from 5001 to 6001. Then I pointed it to the Shares. It could see the PS3, and vice-versa and all appeared well. I then selected "install as a service" and closed the program.

I went into Services (Start -> Programs -> Administrative Tools -> Services) and PS3MediaServer appears with startup type as "auto". I started the service from there, but the PS3 wouldn't see it. Run the program manually and the PS3 sees it, run it as a service and it doesn't.

Googling found many people with similar problems, but I didn't find a workaround.

Then I noticed that when you run the program "manually" (from Remote Desktop) it's running "C:\Program Files\PS3 Media Server\PMS.exe" but when it's run as a service (Right click -> Properties in Services) it's running "C:\Program Files\PS3 Media Server\win32\service\wrapper.exe".

I tried running "C:\Program Files\PS3 Media Server\win32\service\wrapper.exe" manually and got the Windows firewall "Program blocked" message again, I unblocked it, and now the PS3 can see the server and everything streams great.

I like it already, browsing pictures seems slightly faster and I don't have to muck around demuxing my MKVs anymore.

Anyway, I just wanted to pass this along in case it saves someone some time. :)


Top
 Profile  
Thanks  
The following user would like to thank OmniWrench for this post
Comp1962

Attention Guest: Remove this ad by Registering with the MediaSmartServer.net Forums. It's Free!
PostPosted: Tue Jul 12, 2011 9:42 am 
Offline
Newbie
Newbie

Joined: Fri May 20, 2011 7:15 pm
Posts: 2
Thanks: 0
Thanked: 0 time in 0 post
Thank you very much for posting this information.

I am going to tackle this with WHS 2011 this very weekend, I would expect the process to be similar. If I have any issues I will post back and hopefully it will in turn help someone else.

Thanks!


Top
 Profile  
Thanks  
PostPosted: Sun Jun 02, 2013 2:58 pm 
Offline
Max Contributor
Max Contributor

Joined: Fri Jan 25, 2008 4:17 pm
Posts: 1110
Location: Roseville, California
Thanks: 10
Thanked: 22 times in 21 posts
I just installed this for my new sony bravia TV, this thing is awesome. Looks like the WHS add-in was abandoned so I installed the regular install. works very well. the only issue I have with it is I told it I wanted to search in a folder on public and it wont add the folder to the list of streams. I know there are videos there as I store them there while I name them and check quality.


Top
 Profile  
Thanks  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC - 7 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group