It is currently Tue Dec 12, 2017 9:37 pm

All times are UTC - 7 hours [ DST ]

Recent News:



Post new topic Reply to topic  [ 137 posts ]  Go to page 1, 2, 3, 4, 5 ... 10  Next
Author Message
 Post subject: MySql Installer for WHS
PostPosted: Wed Sep 16, 2009 4:40 pm 
Offline
Uber Moderator
Uber Moderator
User avatar

Joined: Sun Dec 02, 2007 3:29 am
Posts: 1736
Location: Brighton, England
Thanks: 27
Thanked: 202 times in 152 posts
Today, I'm also releasing the Beta of MySql Installer for WHS.

This is a straight install of MySql with PhpMyAdmin thrown in as well to make the management of MySql as easy as possible. I don't set a password on MySql so you can do that through either the command line, or through PMA. (which needs PHP, which you can download or use the WHS PHP Installer Add-In)

The MySql Installer for WHS Add-In can be downloaded from here.

Once installed, you can manage MySql using https://SERVERNAME/pma

_________________
Have you tried our Add-Ins? If so, be sure to Rate them at WeGotServed.
Help support MediaSmartServer.Net!


Top
 Profile  
Thanks  
The following user would like to thank Cougar for this post
lemminglover, smr, TAdams

Attention Guest: Remove this ad by Registering with the MediaSmartServer.net Forums. It's Free!
PostPosted: Wed Sep 16, 2009 9:19 pm 
Offline
Moderator
Moderator
User avatar

Joined: Fri Dec 07, 2007 11:18 pm
Posts: 539
Location: Orange County, CA
Thanks: 2
Thanked: 14 times in 13 posts
Installed :cheers: on 475 and 485

I will post any issue I find.

Thanks,

Joe

_________________
If you only have 1 copy of a file you do not have a copy! Back-up off site!!!
If someone wrote a particularly helpful post? Use the "Thank Post" button!


Top
 Profile  
Thanks  
PostPosted: Thu Sep 17, 2009 7:30 am 
Offline
2.5TB storage
2.5TB storage

Joined: Fri May 08, 2009 2:10 am
Posts: 266
Thanks: 2
Thanked: 34 times in 33 posts
I'm getting a 1603 error, curious if this fix from PHP was incorporated into your current MySql version?

=========================================================================================================================================

Version 0.0.5
Release 28/7/2009

Resolved an issue where a user may have renamed the server, and the IUSR account did not match the current server name. In this instance
an MSI 1603 error occurred.

=========================================================================================================================================

Hmm.... Doing "You can rename the account (IUSER_HPSERVER to IUSER_SERVERName), and the only thing you need to do is to set the IIS Guest account name. (IIS Admin, right click the default web site and choose properties, directory security, edit, set the right name (no password needed))." Does not appear to resolve this issue this time....

The description for Event ID ( 100 ) in Source ( MySQL ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: Can't create test file D:\MySQL Databases\BLACK-1.lower-test


Top
 Profile  
Thanks  
PostPosted: Thu Sep 17, 2009 10:25 am 
Offline
Uber Moderator
Uber Moderator
User avatar

Joined: Sun Dec 02, 2007 3:29 am
Posts: 1736
Location: Brighton, England
Thanks: 27
Thanked: 202 times in 152 posts
Yeah it's got the permissions fix from php in it, so it's not that. The error kind of indicates a permissions issue on D:\MySQL Databases\. What permissions have been set on this (they should be inheriting the roots)

_________________
Have you tried our Add-Ins? If so, be sure to Rate them at WeGotServed.
Help support MediaSmartServer.Net!


Top
 Profile  
Thanks  
PostPosted: Sat Sep 19, 2009 11:29 am 
Offline
Newbie
Newbie

Joined: Sat Sep 19, 2009 11:27 am
Posts: 2
Thanks: 0
Thanked: 0 time in 0 post
Hi,

Could you please try to explain a little more detailed how to correct this error ?

I get an 1603 Error also.

Seems really cool to mee to run my own SQL server with PHP

Thanks in advance.

Greetings,

Bert


Top
 Profile  
Thanks  
PostPosted: Sat Sep 19, 2009 12:47 pm 
Offline
2.5TB storage
2.5TB storage

Joined: Fri May 08, 2009 2:10 am
Posts: 266
Thanks: 2
Thanked: 34 times in 33 posts
Cougar wrote:
Yeah it's got the permissions fix from php in it, so it's not that. The error kind of indicates a permissions issue on D:\MySQL Databases\. What permissions have been set on this (they should be inheriting the roots)


It should be what ever the standard permissions are... Watching D:\ I never see D:\MySQL being created, MyPHP runs and installs okay.


Top
 Profile  
Thanks  
PostPosted: Sat Sep 19, 2009 12:52 pm 
Offline
2.5TB storage
2.5TB storage

Joined: Fri May 08, 2009 2:10 am
Posts: 266
Thanks: 2
Thanked: 34 times in 33 posts
connyislief wrote:
Hi,

Could you please try to explain a little more detailed how to correct this error ?

I get an 1603 Error also.

Seems really cool to mee to run my own SQL server with PHP

Thanks in advance.

Greetings,

Bert


You might want to watch your D drive while running the installer and see if a D:\MySQL folder is created for you. If the folder is not being created for you either then perhaps our issue is the same.


Top
 Profile  
Thanks  
PostPosted: Sat Sep 19, 2009 1:10 pm 
Offline
Newbie
Newbie

Joined: Sat Sep 19, 2009 11:27 am
Posts: 2
Thanks: 0
Thanked: 0 time in 0 post
I have the same issue.

No D:\MySQL was created.

Anyone got a solution for this ?


Top
 Profile  
Thanks  
PostPosted: Sun Sep 20, 2009 1:31 pm 
Offline
Uber Moderator
Uber Moderator
User avatar

Joined: Sun Dec 02, 2007 3:29 am
Posts: 1736
Location: Brighton, England
Thanks: 27
Thanked: 202 times in 152 posts
Sorry for the delay in responding, been away for the weekend.

I've tried to reproduce this; and failed. Each install goes in cleanly no matter how many different machines I try it on. Can you both PM me the additions*.log from when you did the install (or try again and choose the latest one) from C:\Documents and Settings\All Users\Application Data\Microsoft\Windows Home Server\logs and we can see why its not creating D:\MySQL Databases?

Also if you can let me know what other Add-Ins or software you have installed on the server?

Thanks.

_________________
Have you tried our Add-Ins? If so, be sure to Rate them at WeGotServed.
Help support MediaSmartServer.Net!


Top
 Profile  
Thanks  
PostPosted: Sun Sep 20, 2009 4:57 pm 
Offline
Moderator
Moderator
User avatar

Joined: Fri Dec 07, 2007 11:18 pm
Posts: 539
Location: Orange County, CA
Thanks: 2
Thanked: 14 times in 13 posts
Messing with my 47X machine and get this when logging into sqladmin

PHP has encountered an Access Violation at 02852BEB

running php addin v1.0

all works fine on my 48x so far

_________________
If you only have 1 copy of a file you do not have a copy! Back-up off site!!!
If someone wrote a particularly helpful post? Use the "Thank Post" button!


Top
 Profile  
Thanks  
PostPosted: Tue Sep 22, 2009 2:34 am 
Offline
2.5TB storage
2.5TB storage

Joined: Fri May 08, 2009 2:10 am
Posts: 266
Thanks: 2
Thanked: 34 times in 33 posts
Action start 4:27:04: InstallFinalize.
CAQuietExec: The service already exists!
CAQuietExec: The current server installed: "c:\Program Files\mysql\bin\mysqld.exe" "--defaults-file=C:\Program Files\mysql\my-whs.ini" MySQL.WHS
CAQuietExec: The MySQL.WHS service is starting.
CAQuietExec: The MySQL.WHS service could not be started.
CAQuietExec:
CAQuietExec: A system error has occurred.
CAQuietExec:
CAQuietExec: System error 1067 has occurred.
CAQuietExec:
CAQuietExec: The process terminated unexpectedly.
CAQuietExec:
CAQuietExec: Error 0x80070002: Command line returned an error.
CAQuietExec: Error 0x80070002: CAQuietExec Failed
Action ended 4:27:41: InstallFinalize. Return value 3.
Action ended 4:27:53: INSTALL. Return value 3.
Property(S): Data = C:\Program Files\mysql\sql-bench\Data\
Property(S): File = C:\Program Files\mysql\mysql-test\lib\My\File\
Property(S): pma = C:\inetpub\wwwroot\pma\

Image
Image


Last edited by Teknmage on Tue Sep 22, 2009 3:14 am, edited 1 time in total.

Top
 Profile  
Thanks  
PostPosted: Tue Sep 22, 2009 2:49 am 
Offline
2.5TB storage
2.5TB storage

Joined: Fri May 08, 2009 2:10 am
Posts: 266
Thanks: 2
Thanked: 34 times in 33 posts
Cougar wrote:
Yeah it's got the permissions fix from php in it, so it's not that. The error kind of indicates a permissions issue on D:\MySQL Databases\. What permissions have been set on this (they should be inheriting the roots)


One issue appears to be that it is not installing to the D:\ drive but rather to the C:\Program Files\ drive. Where it has left behind a C:\Program Files\mysql\mysql-test\extra folder structure. Tried deleting this folder structure, and re running the program, again it fails but now it creates a C:\Program Files\mysql\mysql-test note that the "extra" folder is not created....


Top
 Profile  
Thanks  
PostPosted: Wed Sep 23, 2009 7:25 am 
Offline
Newbie
Newbie

Joined: Sun Sep 20, 2009 11:55 pm
Posts: 2
Thanks: 0
Thanked: 0 time in 0 post
Got the same error here...
First I got this error because of this error (in the eventlog)
[Can't create test file D:\MySQL Databases\homeserver.lower-test]
[Product: MySql Installer for WHS -- Installation failed.]

I created the folder D:\MySQL Databases\ by hand because the installation didn't create it.

After another try I got these in the eventlog:
[Plugin 'FEDERATED' is disabled.]
[Can't open the mysql.plugin table. Please run mysql_upgrade to create it.]
[Fatal error: Can't open and lock privilege tables: Table 'mysql.host' doesn't exist]
[Product: MySql Installer for WHS -- Installation failed.]

Enabled Windows Installer Extended Logging but couldnt find the log file anywhere :-/

What I did find was this log in the D:\MySQL Databases\ directory.

090923 5:32:07 [Note] Plugin 'FEDERATED' is disabled.
c:\Program Files\mysql\bin\mysqld.exe: Table 'mysql.plugin' doesn't exist
090923 5:32:07 [ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade to create it.
InnoDB: The first specified data file .\ibdata1 did not exist:
InnoDB: a new database to be created!
090923 5:32:07 InnoDB: Setting file .\ibdata1 size to 10 MB
InnoDB: Database physically writes the file full: wait...
090923 5:32:07 InnoDB: Log file .\ib_logfile0 did not exist: new to be created
InnoDB: Setting log file .\ib_logfile0 size to 5 MB
InnoDB: Database physically writes the file full: wait...
090923 5:32:08 InnoDB: Log file .\ib_logfile1 did not exist: new to be created
InnoDB: Setting log file .\ib_logfile1 size to 5 MB
InnoDB: Database physically writes the file full: wait...
InnoDB: Doublewrite buffer not found: creating new
InnoDB: Doublewrite buffer created
InnoDB: Creating foreign key constraint system tables
InnoDB: Foreign key constraint system tables created
090923 5:32:08 InnoDB: Started; log sequence number 0 0
090923 5:32:08 [ERROR] Fatal error: Can't open and lock privilege tables: Table 'mysql.host' doesn't exist
090923 5:40:38 [Note] Plugin 'FEDERATED' is disabled.
c:\Program Files\mysql\bin\mysqld.exe: Table 'mysql.plugin' doesn't exist
090923 5:40:38 [ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade to create it.
InnoDB: Log scan progressed past the checkpoint lsn 0 39548
090923 5:40:39 InnoDB: Database was not shut down normally!
InnoDB: Starting crash recovery.
InnoDB: Reading tablespace information from the .ibd files...
InnoDB: Restoring possible half-written data pages from the doublewrite
InnoDB: buffer...
InnoDB: Doing recovery: scanned up to log sequence number 0 46409
090923 5:40:39 InnoDB: Starting an apply batch of log records to the database...
InnoDB: Progress in percents: 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99
InnoDB: Apply batch completed
090923 5:40:39 InnoDB: Started; log sequence number 0 46409
090923 5:40:39 [ERROR] Fatal error: Can't open and lock privilege tables: Table 'mysql.host' doesn't exist
090923 5:53:14 [Note] Plugin 'FEDERATED' is disabled.
c:\Program Files\mysql\bin\mysqld.exe: Table 'mysql.plugin' doesn't exist
090923 5:53:14 [ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade to create it.
InnoDB: Log scan progressed past the checkpoint lsn 0 39548
090923 5:53:15 InnoDB: Database was not shut down normally!
InnoDB: Starting crash recovery.
InnoDB: Reading tablespace information from the .ibd files...
InnoDB: Restoring possible half-written data pages from the doublewrite
InnoDB: buffer...
InnoDB: Doing recovery: scanned up to log sequence number 0 46409
090923 5:53:15 InnoDB: Starting an apply batch of log records to the database...
InnoDB: Progress in percents: 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99
InnoDB: Apply batch completed
090923 5:53:15 InnoDB: Started; log sequence number 0 46409
090923 5:53:15 [ERROR] Fatal error: Can't open and lock privilege tables: Table 'mysql.host' doesn't exist
090923 6:12:22 [Note] Plugin 'FEDERATED' is disabled.
c:\Program Files\mysql\bin\mysqld.exe: Table 'mysql.plugin' doesn't exist
090923 6:12:22 [ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade to create it.
InnoDB: Log scan progressed past the checkpoint lsn 0 39548
090923 6:12:23 InnoDB: Database was not shut down normally!
InnoDB: Starting crash recovery.
InnoDB: Reading tablespace information from the .ibd files...
InnoDB: Restoring possible half-written data pages from the doublewrite
InnoDB: buffer...
InnoDB: Doing recovery: scanned up to log sequence number 0 46409
090923 6:12:23 InnoDB: Starting an apply batch of log records to the database...
InnoDB: Progress in percents: 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99
InnoDB: Apply batch completed
090923 6:12:24 InnoDB: Started; log sequence number 0 46409
090923 6:12:24 [ERROR] Fatal error: Can't open and lock privilege tables: Table 'mysql.host' doesn't exist

I hope this helps a bit...
Greetings,

Mike


Top
 Profile  
Thanks  
PostPosted: Wed Sep 23, 2009 8:25 am 
Offline
Uber Moderator
Uber Moderator
User avatar

Joined: Sun Dec 02, 2007 3:29 am
Posts: 1736
Location: Brighton, England
Thanks: 27
Thanked: 202 times in 152 posts
Teknmage wrote:
[One issue appears to be that it is not installing to the D:\ drive but rather to the C:\Program Files\ drive. Where it has left behind a C:\Program Files\mysql\mysql-test\extra folder structure. Tried deleting this folder structure, and re running the program, again it fails but now it creates a C:\Program Files\mysql\mysql-test note that the "extra" folder is not created....


Interesting as I don't include the test files in the installer. I also dont set Inodb in the ini file I provide so I'm guessing you guys have probably got MySql installed already or something has installed it previously. Might be worth checking around your servers to see if you have any remnants of .ini files maybe in c:\windows or a MySql service on the server?

_________________
Have you tried our Add-Ins? If so, be sure to Rate them at WeGotServed.
Help support MediaSmartServer.Net!


Top
 Profile  
Thanks  
PostPosted: Wed Sep 23, 2009 10:29 am 
Offline
.5TB storage
.5TB storage

Joined: Tue Mar 18, 2008 12:20 am
Posts: 10
Thanks: 1
Thanked: 3 times in 2 posts
AHHHHHHH!

The PHPinstall installed like a charm, MySQL now that was a big issue - It states that it installed ok, but when I try running https://xxxx-server/pma I get the webpage "
phpMyAdmin - Error
Cannot load mysqli extension. Please check your PHP configuration. - Documentation

I have checked everything - un-installed it and re-installed it and the same error pops up.

Any ideas or suggestions - otherwise I think you did a great job - keep up the great work

Badjames_no1

_________________
MSS HP475 + 8TB , 2 GB m, PP2
PC1 Win 7 Ult Quad QX9775 w/6gb m,2x500 GB WD RD-1,2x8800gtx Sli mode
PC2 XP Pro/64 SP3 AMD 3300 w/2gb m 2x120GB Rd 0
PC3 XP Pro/32 SP3 AMD 2400 w/1.5bg m 2x72GB
PC4 LapTop
PC5 XP Pro/32 SP3 P4 1gb m
4TB NAS Raid 10


Top
 Profile  
Thanks  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 137 posts ]  Go to page 1, 2, 3, 4, 5 ... 10  Next

All times are UTC - 7 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group