Media Browser 2.3.0 (Draco) Released

by Damian on January 14, 2011 · 15 comments

in News

The next version of Media Browser (codename Draco) has just been released into the wild.  If you have followed my writings you know that Media Browser is my front end/plugin of choice when it comes to HTPCs.  One interesting change (and hopefully this will help fix the issues I have been experiencing with my library disappearing) is that with Draco Media Browser has now moved to a service based architecture.

Highlights:

  • Media Browser Service. Library refreshes and Validations have been moved to a seperate service freeing the interface resulting in major performance improvements. You can even disable the validation entirely if you want.
  • Configurator enhancements. Plugin updates have been greatly improved. We now have a rollback function, highlighted plugins that have updates and multiple plugin versions!
  • Year sorting improvements
  • Lots of MediaInfo improvements and fixes
  • Podcasts fixes
  • Improved logging
  • A lot of additional options and bug fixes in default theme
  • Resume Tracking enhancements. You can now define when and if resume tracking aka playstate is enabled.

In addition, several plugins have been updated and released:

  • MediaInfo Provider now performs a proper update and includes MediaInfo.dll 0.7.38.0. Also various fixes.
  • High Quality Thumbnails has gotten new libraries thanks to Darklich, properly cleans up after itself and performs a proper update

I haven’t had a chance to test out Draco but with a 3 day weekend ahead of us I should have some time to spend with, so be on the lookout for my thoughts soon. A complete changelog can be found here and Draco can be downloaded here. For more on Media Browser make sure you check out my latest walk through or head over to the Media Browser Community Tracker.





Article by

Hi, my name is Damian, and I'm tech gadget addict! Although I always had some interest in technology, it wasn't until I got my EX470 and more importantly found Mediasmartserver.net, that my interest became an addiction. My goal, aside from world domination and to see the Mets/Broncos win another championship, is to set up the perfect digital home where all my media is available at the click of a button. When I am not writing for Mediasmartserver.net you can find me over at my blog at http://www.adigitalhomeblog.com or follow me on twitter


{ 15 comments }

Don January 14, 2011 at 8:41 am

Damian,

First of all thanks for all you help with my previous posts.

I have a question regarding cover art for my movies stored on my whs.

I pointed media browser to the server share video folder //server videos
all of the movies are stored in this one folder. My question is this about half
of the 500 movies have cover art, ad the rest do not. Also some of the movies that have no cover art when clicked on will come up with some artwork while others have none. I am confused because all of the movies are in the same folder.

Regards,
Don

Damian January 14, 2011 at 9:11 am

Don,

Based on your email address you are a NY Mets fan which means you take priority over all other commentors :-)

Can you confirm, is each movie in its own folder? How did you get your covers?

Alex Kuretz January 14, 2011 at 8:43 am

Yay! Maybe my HTPC will finally sleep! And performance improvements in the UI would be very welcome, especially on my Ion-based Revo. I’m definitely trying this out this weekend.

Damian January 14, 2011 at 9:15 am

Definitely let me know if it helps any. Whenever I test out XBMC I am reminded of how slow the Media Browser UI can be at times, especially when navigating through a list. The disappearing cover art I have been experiencing may have been related to the Cover Art plugin. I haven’t had enough time to troubleshoot and it really killed using MB for me, so for the time being I have just been stuck with using the other players in my house.

don January 14, 2011 at 9:40 am

long suffering mets fan. All movies are in 1 folder the videos folder stored on whs

Damian January 14, 2011 at 9:51 am

OK, so Media Browser does not work that way, each movie needs to be in its own folder. There are several tools out there that will do this for you automatically if you are interested (http://www.thehtpc.net/search/file2folder/).

So for example, under my Videos Share folder, I have a separate folder for each movie, and then in that folder is the actual movie file.

If you don’t want to keep your movies in individual folders then unfortunately Media Browser won’t work, and instead I would recommend looking at XBMC which doesn’t have this requirement

Kubla January 14, 2011 at 11:54 am

Do all the movies have to be in the shared videos folder or can you make a shared movies folder for them?

Damian January 14, 2011 at 11:57 am

They can be in any shared folder you want, as long as the PC running Media Browser can access

Preston January 25, 2011 at 10:58 pm

I actually keep most of my movies in 1 folder too, and media browser works flawlessly. Only problem Im running into is my WHS will freeze, and if I load media browser before I find out it froze, then it takes forever for media browser to re-download the art .

Alex Kuretz January 15, 2011 at 9:39 pm

Well I updated both my HTPC’s and have to say that there is a significant improvement in responsiveness of the UI, I’m very pleased about that. Even the pokey Ion-powered Revo is fairly quick to navigate.

And for perhaps the first time it remembered my Watched status on my files!

I’ve not yet done a lot of testing but so far I’m pleased.

Unfortunately it doesn’t seem to have resolved my issues with the HTPC waking up randomly and not going back to sleep.

Kryspy January 16, 2011 at 8:24 am

Hi,

The randon waking of the PC is a known Windows 7 issue and has nothing to do with Media Browser itself. Google will find the fix for you.

Kryspy

Alex Kuretz January 16, 2011 at 2:26 pm

Thanks, I’ll look for more details on that. Another forum member has also seen the issues with the HTPC going back into sleep mode when MediaBrowser is active, so I’m inclined to think there is still some issue there.

don January 16, 2011 at 6:17 pm

thanks xbmc worked great for me saw all 575 movies and got art as well. Thanks for your advive.

Rehards,
Don

Aaron February 28, 2011 at 7:09 pm

I have to say since installing this update about a month ago I have had more problems with disappearing cover art than before. Always before it was one or two movies every so often that the cover art was not displayed, now it is consistently about 5 or 6 different movies every time I open Media Browser. I also haven’t seen the improvements in the responsiveness of the UI as noted above. Any suggestions?

Damian March 1, 2011 at 6:35 am

Are you using the Cover Art plugin?

Comments are closed, visit the forums to continue the discussion.

Previous post:

Next post: