Forum Spotlight: Windows Media Connect Limitation

by Nigel Wilks on January 13, 2010 · 10 comments

in Forum Spotlight

Forum member “crzyhomer″ has uncovered a little known fact with Windows Media Connect in that you can only have 10 “Allowed” devices. His issue manifested itself when adding a new Playstation 3 to the network and he received a “Media Server Error: DLNA Protocol Error 501″.

To see how many devices your server has registered (and to remove any that are surplus) is fairly simple but requires that you open a Remote Desktop Session onto your Windows Home Server.

Once logged on to the server, click Start, Run then type C:\PROGRAM FILES\MEDIA CONNECT\WMCCFG.EXE and click OK. This will then open the Windows Media Connect Configurator and show you a list of devices that are registered on your server similar to the screenshot below.

WMCCFG.EXE

By simply clicking on a surplus device, and clicking on Remove is all that it takes to resolve the “Media Server Error: DLNA Protocol Error 501″.

After doing some further research of my own into this as Google searches were not very forthcoming, it may well be little known but Microsoft do state it’s limitation in many resources related to Windows Media Connect. Admittedly it’s not easy to spot but I found a reference in the Introducing Windows Media Connect document.

“Windows Media Connect is compatible with most digital media receivers (DMRs). You can use Windows Media Connect to share content with up to 10 devices at a time.”

Has anyone else come close to 10 devices in the home? Is a 10 user limit too low? Let us know in the comments or in the forums.

Update: Wonko has found an Add-In that accomplishes the tasks outlined above which means you wont need to Remote Desktop onto your server. I have installed this and it manages the task perfectly!




Article by

I'm a Technical Architect based in the UK predominantly working on Windows Server and Active Directory based solutions. I'm also a Microsoft Windows Home Server MVP and moderator/author at http://www.mediasmartserver.net. I've released the FirePlay for Windows Home Server, WHS PHP Installer, MySql Installer for WHS and Wordpress Installer for WHS Add-Ins as well as co-author of the SanEncore and WHS Health Add-Ins with Alex Kuretz.


{ 10 comments }

Marcos Sebastian January 13, 2010 at 11:06 pm

Hey Nigel:
Thanks for this article. I was getting the same error on our new PS3. I thought it was some port issue with the router and did not troubleshoot it.
I followed your instructions and found about 14 items registered in the Windows Media Connect configurator. Half of them were old. Once I removed them, the error message disappeared.

Thanks again!

Cougar January 14, 2010 at 12:54 am

Great! Thanks for the feedback Marcos.

Alex Kuretz January 14, 2010 at 8:48 am

That’s great to hear Marcos, glad the article helped!

Craig January 15, 2010 at 4:45 pm

Excellent post! I’m up to six sonos zones, four ps3′s, an xbox, three laptops, two desktops and a lousy netbook. I’ve been getting this message on 2 of the ps3′s and this has solved the error message.

Thank you for the news.

craig

Wonko January 17, 2010 at 9:54 am

Could I also use PV Connect for that?
It gives me “a bit more” information but can be used also for an overview as well as for removing not longer used components.

Best Regards
Wonko

Alex Kuretz January 17, 2010 at 10:23 am

Hi Wonko, you can certainly use PV Connect (aka Twonky) for your Media Streaming and to my knowledge it doesn’t suffer from this same limitation.

Wonko January 18, 2010 at 9:36 am

I’m back again:
There’s another AddIn, described in
http://blog.paks.no/2009/04/09/media-connect-configuration-addin/.
You could use this to avoid the way via remote login and so on…
Best regards
Wonko

Cougar January 18, 2010 at 10:19 am

Good spot! I’d never heard of that add-in and it does indeed work perfectly on my system.

Nick April 20, 2011 at 6:31 pm

Great info saved me a load of work.
Thanks

jessica@Allconnect July 8, 2011 at 1:59 am

i got windows media connect set up on my computer and i able to stream my pictures and music from them onto my 360, i was wondering is there a way to stream videos as well. when you click on videos on the 360 dashboard it says i don’t have any on my hd. so I’m thinking that you cant stream videos, just play ones that are downloaded onto my 360.

Comments are closed, visit the forums to continue the discussion.

Previous post:

Next post: